HomeScreensavers Planet  »  Help  »  Message Board  »  Razer screensavers: white screen?

Razer screensavers: white screen?

I m using a screen saver from razer and its coming up white and nothing else

Anonymous1 year agoWindows 10 x64, Google Chrome


9 replies

  • It looks like the Razer Fragged and Razer Respawn screensavers (available here) have an implementation of Flash that is no longer supported by Windows 7, 8 and 10. They may still work on older versions of Windows like XP and Vista, but I can see that you're running Windows 10. They don't seem to work on macOS either.

    I may be able to repackage the screensavers in a way that will make them run on Windows 10 (and macOS), but that may take some time.

    Rob (Screensavers Planet)1 year ago

  • If you managed to do it, can you maybe post a downloadlink on here?

    OmegaRogue2 months ago

  • Not at the time, but I did manage to repackage the Razer Fragged screensaver just now, and I tested it to work on Windows 10. I only repackaged the Fragged screensaver because it was a bit more interesting than the Respawn screensaver.

    You can download the Razer Fragged screensaver directly via this link.

    Hope it works for you, too!

    Rob (Screensavers Planet)2 months ago

  • Thanks, that was the one i wanted to use

    OmegaRogue2 months ago

  • How does the executable for the screensaver work? How do i use it?

    OmegaRogue2 months ago

  • Are you on Windows? If so, the executable is an installer that will guide you through the steps. Note that you may have to bypass a SmartScreen warning first.

    If you're on a Mac, I'll have to build a different file for that. Just let me know.

    Rob (Screensavers Planet)2 months ago

  • ok i got it working, thanks

    OmegaRogue2 months ago

  • it was just that avast thought it was a virus, but i got it working

    OmegaRogue2 months ago

  • Sorry about that, false alarms are quite common with screensavers. The VirusTotal scan report did not raise a flag with Avast, or with any of the other anti-virus engines, so I did not expect a problem. I'm glad you got it working anyway. Enjoy!

    Rob (Screensavers Planet)2 months ago

Post a reply

Lock This post was automatically locked to new replies after 30 days of inactivity.

Please start a new post on the message board if you need our help.