HomeScreensavers Planet  »  Help  »  Message Board  »  Newer Version Required for Mac OS X 10.12.6

Newer Version Required for Mac OS X 10.12.6

Hi there, after a lot of difficulty I got a notification saying that a newer version is required for my operating system and to contact the vendor this. Is that possible, or is there another way? Thanks.

Linked pages

AM7 months agoMac OS X 10.12.6, Google Chrome


3 replies

  • Hello,

    A newer version of the Fliqlo screensaver is not available. The latest version is 1.7.1 and should work on your version of Mac OS X (10.12). Perhaps you can try installing an older version, such as 1.5, which you can download here.

    Did you try restarting your Mac? It seems to have helped in this previous case.

    Thanks for posting to the message board, and please let me know how it goes.

    Rob (Screensavers Planet)7 months ago

  • Yes I read previous comments and tried restarting it, which did not work. I downloaded the previous version which worked for some reason. Thanks!

    AM7 months ago

  • Great! I can't explain it either, but I'm glad it's now working for you.

    Enjoy the screensaver, and thanks for visiting!

    Rob (Screensavers Planet)7 months ago

Post a reply

Lock This post was automatically locked to new replies after 30 days of inactivity.

Please start a new post on the message board if you need our help.