HomeScreensavers Planet  »  Help  »  Message Board  »  i cant keep fliplo screensaver for my old version laptop like win 7

i cant keep fliplo screensaver for my old version laptop like win 7

i cant keep fliplo screensaver for my old version laptop like win 7

Linked pages

Anonymous7 months agoWindows 7 x64, Google Chrome


1 reply

  • The Fliqlo screensaver for Windows was recently updated so that it wouldn't require Flash technology, because this is no longer supported by Windows.

    Unfortunately, the latest version (1.5.1) only works on Windows 8.1 and Windows 10.

    You can try downloading an older version like 1.1 or this standalone screensaver file, but I can't guarantee that either one of these will work for you.

    Those older versions do require the Adobe Flash Player plug-in to be installed.

    Rob (Screensavers Planet)7 months ago

Post a reply

Lock This post was automatically locked to new replies after 30 days of inactivity.

Please start a new post on the message board if you need our help.