HomeScreensavers Planet  »  Help  »  Message Board  »  Does not work with macOS 10.14.5

Does not work with macOS 10.14.5

Does not work with macOS 10.14.5. Is there a newer version?

Linked pages

Stew3 weeks agomacOS 10.14.5, Safari


1 reply

  • Hello Stew,

    This seems to be the latest version of the screensaver, I'm afraid. It was released quite some time ago, when OS X 10.5 (Leopard) was current, and the screensaver thankfully continued to work for macOS up until the release of 10.14 (Mojave), with which Apple broke backward compatibility for hundreds of screensavers.

    I don't expect the screensaver to be updated for modern Macs, unfortunately.

    Sorry for the inconvenience!

    Rob (Screensavers Planet)3 weeks ago

Post a reply

* Enter your e-mail address to be notified when a new reply is posted. You can unsubscribe at any time.