HomeScreensavers Planet  »  Help  »  Message Board  »  Cannot get into settings now after using reg.fix

Cannot get into settings now after using reg.fix

Last year this fix was not necessary. Not sure why it is now. But the screensaver did finally install and works. But clicking on the settings button no longer works. Used to this would allow to change sounds, graphics, or scenes. No nothing. Any ideas?

Linked pages

Shadow1 week agoWindows 7 x64, Firefox


9 replies

  • Hello Shadow,

    What's the error message you get when you try to open the settings menu?

    Still seems to be working here on a Windows 10 computer.

    Did you run the graphics test during the installation process?

    Rob (Screensavers Planet)1 week ago

  • When I click on settings a window pops up and says "Settings.dat has stopped working." Then gives me the option to continue to look online for solution or close it out. I'm using Windows 7 Pro and installed this last Christmas it worked fine even without the patch. Now I'm having to use the patch and getting the error.

    Shadow1 week ago

  • Oh and I reinstalled Windows recently and went looking for this screensaver again. This time when I tried to install it wouldn't install or connect for flash? I installed the reg.fix file and it installed fine. I did do the graphics test. As I said it runs great just can't change the settings like before. Great site by the way.

    Shadow1 week ago

  • Thanks!

    In 2016, someone else reported that error message with the Living Marine Aquarium 2 screensaver, which is from the same developer. Unfortunately, I can't seem to replicate it on any of my computers, so it's hard to find a solution.

    Have you tried temporarily disabling your anti-virus software, if you're not using the built-in Windows Defender software? Sometimes these can interfere.

    Rob (Screensavers Planet)6 days ago

  • I turned off firewall and antivirus. Still doesn't work. It is strange last year I downloaded the screensaver and it worked fine without the patch. And no errors. I will try it in Safe Mode and see if it works there. If so then it something on my end. Thanks for the suggestions.

    Shadow6 days ago

  • Tried it in safe mode, same error. I also installed the Aquarium screensaver to test it, same thing happened. So not sure.

    Shadow6 days ago

  • That's too bad. If you're planning on upgrading to Windows 10, as Windows 7 users will no longer be receiving (security) updates as of January 14, it's possible that doing so may also resolve this issue. However, not knowing the cause, I can't guarantee it.

    I'll try to think of other solutions in the meantime. Sorry for the inconvenience!

    Rob (Screensavers Planet)6 days ago

  • Restored to an earlier saved image. Still having the same problem. Also when the screen saver tried to connect to the internet to install flash it wouldn't connect even though I allowed it in the firewall. I installed the flash myself and still problems with settings. It says something about app crash and something not registered? No plans to upgrade to Windows 10 even though I have it. Thanks anyway for the help.

    Shadow6 days ago

  • Yes, the installation program fails to recognize that you already have the Flash plug-in installed, then tries to download it from the internet, but it's looking for a very old version that is no longer available, so it quits. That's what the patch is for: it essentially tricks the program into thinking that old version of Flash is installed.

    Very strange that reverting to an earlier image gives the same result, even though you didn't have the problem at the time. Anyway, if I find something I'll report back.

    Rob (Screensavers Planet)6 days ago

Post a reply

* Enter your e-mail address to be notified when a new reply is posted. You can unsubscribe at any time.